On Fri, Oct 20, 2000 at 01:01:59PM +0100, Chris Withers wrote:
> This one is probably the most useful of the lot ;-)
> >From: Michel Pelletier <[EMAIL PROTECTED]>
> >Well, Jim, Evan, Brian and I pow-wowed yesterday and came up with an
> >interesting change. The world 'Method' is too overlaoded, as it means
> >too much to too many people. Also, Python Methods don't work like
> >methods in python, which was my argument, but they are very useful and
> >there are sound reasons for them working like they do (which J, E and B
> >convinced me of yesterdat). We have decided to change the name of
> >Python Methods to something else, the current candidate being 'Python
> >'Script' objects make a lot of sense, they don't overload the concept of
> >methods, they describe an action that people commonly want to do (script
> >the web) and they clear up a lot of potential confusion for newbie and
> >old-hat alike.
sucks rocks (from a security standpoint). And from common web convention,
it would appear that PythonScript would run on the client side, rather
than the server side. Since the -let suffix appears to have taken on
a server side connotation, perhaps that can be used.
Python Function is not quite right, as it is fairly common (for me, at
least) to define some helper functions in a Python Method. But it is
better than Python Script.
So, I guess my preferences would be:
in descending order of preference.
> Zope-Dev maillist - [EMAIL PROTECTED]
> ** No cross posts or HTML encoding! **
> (Related lists -
> http://lists.zope.org/mailman/listinfo/zope )
Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists -