* The Doctor What ([EMAIL PROTECTED]) [001109 15:18]:
> I'm curious, you posted a message about SiteAccess.  I have the same
> problem, with Debian (Zope 2.2.2 and I've tried SiteAccess 2.0.0b3
> and b4).
> It producing the same errors you have, but in addition, I have this
> info from the stupid log file:
> 2000-11-09T20:09:18 ERROR(200) Zope Couldn't install SiteAccess
> Traceback (innermost last):
>   File /usr/lib/zope/lib/python/OFS/Application.py, line 488, in install_products
>     (Object: ApplicationDefaultPermissions)
>     (Info: SiteAccess)
>   File /usr/lib/zope/lib/python/Products/SiteAccess/__init__.py, line 12, in 
>   File /usr/lib/zope/lib/python/App/ProductContext.py, line 323, in registerHelp
> OSError: [Errno 2] No such file or directory
> I have no idea what's going on, and any help from you or the zope
> mailing list would be appreciated.

I figured it out.  With a little help from my friends.  This product
is missing a 'help' directory.  I'm not sure if this is a debian
feature or not, but attached is a patch to let zope load it whether
the directory exists or not.

I basically wrapped a try around the part of the code that looks for
the help directory and files within it.  This is the file
App/ProductContext.py, btw.

I'll see about fixing SiteAccess (and Plugin, which has the same
problem) for Debian.


Computers are useless.  They can only give you answers.
          -- Pablo Picasso

The Doctor What: "What, Doctor What"             http://docwhat.gerf.org/
[EMAIL PROTECTED]                                                   KF6VNC

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to