Hi all,

I'm trying to get InterbaseStorage working on Win32.

I've got all the requisite parts and they all seem to be working OK (well,
kinterbasdb and mxDateTime do) outside Zope in plain Python.

When I try and import _kinterbasdb.dll, from within Zope I'm getting an
error message:

Unable to initialize mxDateTime
Traceback (innermost last):
  File "D:\Zope230b2\z2.py", line 565, in ?
    exec "import "+MODULE in {}
  File "<string>", line 1, in ?
  File "D:\Zope230b2\lib\python\Zope\__init__.py", line 113, in ?
    m=imp.load_module('Zope.custom_zodb', m[0], m[1], m[2])
  File "D:\Zope230b2\custom_zodb.py", line 1, in ?
    from Products.InterbaseStorage.InterbaseStorage import InterbaseStorage
line 94, in ?
    import kinterbasdb
  File "D:\Python\Lib\kinterbasdb.py", line 4, in ?
    import _kinterbasdb
AttributeError: mxDateTimeAPI

Obviously (to me), since Zope has it's own DateTime module, kinterbasdb is
looking there for something and not finding what it expects.

I've tried monkeying with the Python path to resolve it, but even when it's
searching in the right place I'm still getting the error, so I'm at a loss.

Has anyone else tried this, and did you get any joy?

Is anyone else using mxDateTime (I think it's a pre-requisite of mxODBC)?
I've seen one other post about the exact same problem, but with no

Anyone got any ideas?


Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to