On Wed, 14 Feb 2001, Steve Alexander wrote:
>  > "R. David Murray" wrote:
>  >> catent.getobject()
>  >>
>  >> That would seem to be a lot more OOish.
> 
> In 2.3 you can call catent.getObject(). You can pass an optional REQUEST 
> in as an argument, to support lookup via resolve_url rather than 
> restrictedTraverse.

Thanks muchly, I didn't see that method in the catalog source when I looked.
I forgot to look for the mybrains definition <kicks self>.

Howevever, I'm still getting 'None' as the result.  If I print out, say,
catent.id, I see the correct ID for the object I'm trying to retrieve.

It doesn't make sense that this is failing.  I must be doing something
stupid but I still can't see it.  I tried calling getObject both with
and without REQUEST as a parameter, with the same result.

I guess it's time for some more source spelunking.

--RDM


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to