Hello!

There are two copies of the _mysql.pyd file on my disk:
 
the one I built yesterday is here
   C:\Python20\win32comext\MySQL-python-0.3.5\build\lib.win32-2.0

and there's another one here that I didn't know about here:
   C:\Python20
I'm not sure where that one came from...

Anyway, I took the _mysql.pyd from 
   C:\Python20\win32comext\MySQL-python-0.3.5\build\lib.win32-2.0

and tried putting it in <zopedir>bin/lib

But then when I tried to startup zope, it died. No error messages. 
It just tried to start and then died (on win, this is a console 
window that opens and closes itself)

I then tried putting it in 
   C:\zopes\chikoon\lib\python\Products\ZMySQLDA
but had the same results.

Sorry to continue with the saga, but at least there's no
copy in html this time! I apologize to everyone for that...

bye!
mike blake


phil wrote:
> RE: [Zope-dev] MySQL-python-0.3.5 with ZMySQLDAMike,
> You need to put the file _mysql.pyd into your PYTHONPATH.
> Try putting it into the same folder as the ZMySQLDA or into
> <zopedir>bin/lib.  Either should work OK.

mike wrote:
>> Ok, I installed Microsoft Visual C++ from Studio 6, and
>> after I did a successful build and install of the
>> setup.py file for the MySQL-python-0.3.5
>> I installed it in a folder in my python directory:
>> C:\Python20\win32comext\MySQL-python-0.3.5

>> the error reads as follows:
>> Traceback (innermost last):
>> File C:\zopes\chikoon\lib\python\OFS\Application.py, line 536 in import_products
>>    (Object: string)
>> File C:\zopes\chikoon\lib\python\Products\ZMySQLA\__init__.py, line 91, in ?
>> File C:\zopes\chikoon\lib\python\Products\ZMySQLA\DA.py, line 91, in ?
>> File C:\zopes\chikoon\lib\python\Products\ZMySQLA\db.py, line 89, in ? 
>> ImportError: No module named _mysql

--
[[EMAIL PROTECTED] chikoon]$ whoami
Mike Blake

_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to