I tried this in the most recent 2.3 branch:

<dtml-var "catalog({})">

And it returned all objects.  Are you sure the mapping is empty?

The collector is the right place for things like this.  I hope it's not
broken.  :-(

----- Original Message -----
From: "Edmund Goppelt" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Thursday, April 05, 2001 11:54 AM
Subject: [Zope-dev] Possible ZCatalog Bug


> A ZCatalog when passed an empty mapping of search terms returns no
> records found in Zope 2.3.1, instead of all records.  This is not the
> way I remember ZCatalog working in previous versions of Zope.  Is this
> a bug?
>
> Too, can someone clue me in on the proper place to look for bugs in
> Zope before posting an email like this one?  I really hate to take up
> people's time raising known bugs.  Maybe I just don't know how to use
> it, but the bug collector seems to be out of date or broken or both.
>
> --
>
> Ed Goppelt
>
> _______________________________________________
> Zope-Dev maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope-dev
> **  No cross posts or HTML encoding!  **
> (Related lists -
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope )
>


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to