A wierd one.

When I tried to restart my Zope earlier, I got the following:

  2001-04-26T18:25:03 ERROR(200) Zope Couldn't import Products.WebFactory
  Traceback (innermost last):
    File /usr/local/ZopeCVS/lib/python/OFS/Application.py, line 528, in import_products
      (Object: string)
    File /mnt/zope/WebFactory/Products/WebFactory/__init__.py, line 11, in ?
  ValueError: bad marshal data

line 11 was this:

  import PropertiesTool, MembershipTool, ActionsTool

The only thing I could think of trying was deleting all the .pyc
files, but it made no difference.  I thought, so it's barfing on one
of those modules, I'll put them on separate lines to find out.  And
when I did that, it worked.  It also works with my old cvs version
which didn't work earlier.

Couldn't find anything anywhere on the web about that exception, and I
thought it was freaky enough to post to the list.  Anyone seen it


Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to