I just tried to restart zope and got a core dump.  The backtrace
(pasted below) indicated a problem with the binascii module, and sure
enough, trying to import it reproduced the segfault.  I reinstalled
python and it all worked again.

This isn't strictly a Zope issue but I wondered if anyone's seen
this before, or can explain what might have happened?  I'm a bit out
of my depth when it comes to this kind of thing...




(top of backtrace follows)

#0  0x40181ba3 in frame_dummy ()
   from /home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so
#1  0x40181a01 in _init ()
   from /home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so
#2  0x40130c0a in dl_open_worker (a=0xbfffaa48) at dl-open.c:199
#3  0x4000ac3b in _dl_catch_error () at dl-error.c:99
#4  0x40130d1d in _dl_open () at dl-open.c:210
#5  0x4002e3d3 in dlopen_doit (a=0xbfffab58) at dlopen.c:41
#6  0x4000ac3b in _dl_catch_error () at dl-error.c:99
#7  0x4002e8b9 in _dlerror_run (operate=0x4002e3a8 <dlopen_doit>, 
    args=0xbfffab58) at dlerror.c:125
#8  0x4002e393 in __dlopen_check (
    file=0xbfffaea4 "/home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so", 
mode=2) at dlopen.c:53
#9  0x8069e14 in _PyImport_GetDynLoadFunc (fqname=0xbfffb334 "binascii", 
    shortname=0xbfffb334 "binascii", 
    pathname=0xbfffaea4 "/home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so", 
fp=0x8266ff8) at dynload_shlib.c:81
#10 0x80640c7 in _PyImport_LoadDynamicModule (name=0xbfffb334 "binascii", 
    pathname=0xbfffaea4 "/home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so", 
fp=0x8266ff8) at ./importdl.c:42

#11 0x806279e in load_module (name=0xbfffb334 "binascii", fp=0x8266ff8, 
    buf=0xbfffaea4 "/home/Zope-2.3.2-src/lib/python2.0/lib-dynload/binascii.so",
 type=3) at import.c:1236
#12 0x8063355 in import_submodule (mod=0x80b7bcc, 
    subname=0xbfffb334 "binascii", fullname=0xbfffb334 "binascii")
    at import.c:1755
#13 0x8062f53 in load_next (mod=0x80b7bcc, altmod=0x80b7bcc, 

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to