I tried using structured text for some documentation I wrote in portuguese,
but the accented characters like , , , or  break the parsing of markups
like *emphasis*, 'code' or _underline_, and in portuguese we get a bunch of
those with every sentence, you know... :-)

The result is the literal apearance of some characters that should be markup
and some opening and closing mismatch of markup when there are more than one
occurrence of the same markup, like when you try to *emphasize* twice in the
*same* paragraph.

This is probably due to parsing with python's
string.letters which doesn't include accented letters unless you set the
locale. Now the funny thing is that even when I set -L to, say, pt_BR at Zope
start (and my glibc has correctly configured locales for pt_BR),
structured-text still doesn't parse accented letters correctly.

Investigating that, I found out that if you put, in a 'Script (Python)' the

  import string
  return string.lowercase

it will print 'abcdefghijklmnopqrstuvwxyz' instead of

Which is what you get in a python interpreter if you type::

  import locale
  locale.setlocale(locale.LC_ALL, "pt_BR")
  import string
  print string.lowercase

Assuming you have a correctly configured pt_BR locale in a Linux machine.
This exercise also gives the same results with a correctly configured en_US

Has anyone else stumbled onto this?

Speaking of locales, how do I set locale for Zope in a WinNT/2000
environment? It seems like posix locale strings aren't valid strings for
locale.setlocale() in Windows.

  Cheers, Leo

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists -
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to