The CVS contains a fixed version for this problem.

Andreas
----- Original Message -----
From: "Adrian Hungate" <[EMAIL PROTECTED]>
To: "Dieter Maurer" <[EMAIL PROTECTED]>; "Robert Rottermann"
<[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>
Sent: Friday, October 26, 2001 17:51
Subject: Re: [Zope-dev] WebDAVLocks lost in "Control_Panel" (was:: [ZPT] how
to unlock a webdav locked element ????)


> I suspect this is a bug. I thinmk it is due to upgrading your data.fs from
> an earlier version of Zope. At some point in time Control_Panel has been
> created as a object in data.fs, and this object has an _objects tuple that
> contains the objects from 2.2 or more likely 2.3...
>
> I have this at work, where the same data.fs has been upgraded from 2.1.x
to
> 2.4 and I had to manually remove the Control_Panel instance's "_objects"
> tuple, then everything worked fine.
>
> I do not see this at home where I have a fresh 2.4.1 install.
>
> Adrian...
>
> --
> The difficulty of tactical maneuvering consists in turning the devious
> into the direct, and misfortune into gain.
> - Sun Tzu
>
> ----- Original Message -----
> From: "Dieter Maurer" <[EMAIL PROTECTED]>
> To: "Robert Rottermann" <[EMAIL PROTECTED]>
> Cc: <[EMAIL PROTECTED]>
> Sent: Sunday, October 21, 2001 4:59 PM
> Subject: [Zope-dev] WebDAVLocks lost in "Control_Panel" (was:: [ZPT] how
to
> unlock a webdav locked element ????)
>
>
> > Dieter Maurer writes:
> >  > Robert Rottermann writes:
> >  >  > I do not really understand this answer.
> >  >  > Should there be such lock management??
> >  >  > I have not found it?
> >  > Sorry, you are right.
> >  >
> >  > I was convinced, I saw it there. But when I checked after receiving
> >  > your reply, I did not find it either. Maybe wishful thinking....
> > I rechecked (do not like to be wrong...):
> >
> >   There should be a "DavLocks" entry in the "Control_Panel"
> >   between "Versions" and "Products".
> >
> >   I am now sure, I have seen it.
> >
> >   It is still in the code
> "App.ApplicationManager.ApplicationManager._objects"
> >   but "objectItems" now longer finds it and therefore, it is no longer
> >   shown in the control panel.
> >   I do not (yet) understand why....
> >
> > You can use it anyway:
> >
> >     http://<your zope>/Control_Panel/DavLocks/manage
> >
> >
> > I will report, when I found out why it is no longer shown.
> >
> >
> > Dieter
> >
> > _______________________________________________
> > Zope-Dev maillist  -  [EMAIL PROTECTED]
> > http://lists.zope.org/mailman/listinfo/zope-dev
> > **  No cross posts or HTML encoding!  **
> > (Related lists -
> >  http://lists.zope.org/mailman/listinfo/zope-announce
> >  http://lists.zope.org/mailman/listinfo/zope )
> >
>
>
> _______________________________________________
> Zope-Dev maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope-dev
> **  No cross posts or HTML encoding!  **
> (Related lists -
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope )
>


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to