I need some debugging help with a problem I've had with 2.4 and 
ZClasses.  I have been completely unsuccessful in tracking this one down 
so I can reproduce it and file a proper bug report on it.

Specifically, while developing ZClasses (occasionally deleting and 
recreating them, i.e. to change base classes), I will often get to a 
point where I get a traceback ending in

        NameError: global name 'ClassName' is not defined

I'm using the default constructor DTML method in this case, although a 
python script yields the same error.

I thought I had this trapped in the wild, as I backed up Data.fs with 
the broken behavior, then exported the ZClass products this particular 
one depended on, made a new Data.fs, and reimported them.  They worked. 
  So then I restored the old Data.fs and it was suddenly working (no 
amount of packing, restarting, or cleanGlobals-ing could get me this far 
before, but somehow backing up and restoring Data.fs did...?)

I'm really stumped here.  Anyone have a clue or three?  I'm willing to 
do some debug legwork if I can catch it again...

Matt Behrens <[EMAIL PROTECTED]>
System Analyst, Baker Furniture

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to