Hi,

I posted to [EMAIL PROTECTED] regarding this error with no useful reponse.

I am running Zope-2.4.1 on linux with python2.1.1.  Whenever I try to
pack the database I get:

Error Type: FileStorageError
Error Value: The database has already been packed to a later time or no
changes have been
             made since the last pack

traceback (innermost last):
  File /home/zope/Zope-2.4.1-src/lib/python/ZPublisher/Publish.py, line
223, in publish_module
  File /home/zope/Zope-2.4.1-src/lib/python/ZPublisher/Publish.py, line
187, in publish
  File /home/zope/Zope-2.4.1-src/lib/python/Zope/__init__.py, line 226,
in zpublisher_exception_hook
    (Object: Fake)
  File /home/zope/Zope-2.4.1-src/lib/python/ZPublisher/Publish.py, line
171, in publish
  File /home/zope/Zope-2.4.1-src/lib/python/ZPublisher/mapply.py, line
160, in mapply
    (Object: manage_pack)
  File /home/zope/Zope-2.4.1-src/lib/python/ZPublisher/Publish.py, line
112, in call_object
    (Object: manage_pack)
  File /home/zope/Zope-2.4.1-src/lib/python/App/ApplicationManager.py,
line 419, in manage_pack
    (Object: LockableItem)
  File /home/zope/Zope-2.4.1-src/lib/python/ZODB/DB.py, line 535, in
pack
  File /home/zope/Zope/lib/python/ZODB/FileStorage.py, line 1240, in
pack
    (Object: /home/zope/instance/var/Data.fs)
FileStorageError: (see above)

I have tried making changes to the database, setting the system clock
forward several years, and it made no difference.  I also commented out
the redundancy check at line 1240 in FileStorage.py and tried the pack. 
In that case, it was seemingly successfull, except that the DB size
didn't reduce.

Any ideas on how my DB was corrupted and how I can fix it?

(I am happy to provide the 1.5gig Data.fs if that would help ;-) )


terry

-- 
Terry Kerr ([EMAIL PROTECTED])
Chief Technical Officer
Adroit Internet Solutions (www.adroit.net)
Phone: +61 3 9563 4461
Fax: +61 3 9563 3856
ICQ: 79303381

_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to