Hi Harald,

On Wed, 2001-12-05 at 14:32, Harald Koschinski wrote:
> Daniel Duclos wrote:
> >     I have a zope that is dumping signal 11 every 40 minutes or so. I have tried 
> >recompile python 2.1.1 with-threads without-pymalloc, recompile Zope with it, 
> >recompile ZPAtterns, recompile and instal MYSQL for Python 0.9.1, upgraded to 
> >Zope 2.4.3, all this on a Debian Linux box.
> >     Nothing changed... still restarting...
> >     Anybody, please, has any ideia on this matter?
> >     Please, let me know if there's any relevant info that I forgot to mention 
> >abot my case!
> >     Thanks in advance!!
> >
> I have the same problem since we are live :-(((
> I have the same versions running like you and I tried  the same to fix - 
> but no change.
> What is your state with this problem. Fixed ? How?

It's not fixed, but we managed to make it bearable so as not to lose the

by replacing LoginManager with exUserFolder we managed to bring down the
zope restart time from 5 min (we have a HUGE Data.fs) to 20 secs, and by
installing ZEO we brought down the restart time to between 2 and 8 secs.
By increasing the caching of requests we managed to increase the time
between restart from 15 min to 2 hours. That and a nicely formated
Apache error page for Proxy Errors, for the lucky bastards who happen to
hit the server in the exactly 2 seconds of restart, managed to calm down
the client enough for us to breath.

I'll try the requestprofiler tip Chris gave, but I don't have much hope,
since we use mysql for authentication and the site is authenticated
mostly everywhere.

We are seriously considering droping mysql for postgresql.

        Cheers, Leo

Ideas don't stay in some minds very long because they don't like
solitary confinement.

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to