On Fri, Mar 08, 2002 at 04:12:31PM -0600, Ross J. Reedstrom wrote:
> On Fri, Mar 08, 2002 at 08:55:56PM +0100, Dieter Maurer wrote:
> > Ross J. Reedstrom writes:
> >  > Boy, it's been a long time since I've hung around here. Anyway, I think
> >  > we've found a bug somewhere in the zope transaction machinery.
> > A really long time ago someone reported (just once) a bug in Zope's
> > transaction system.
> > 
> >    When I remember right, the problem occured when
> >    there was an exception in the late stages of transaction processing.
> >    This caused Zope to forget about aborting some other transactions.
> > 
> > Not sure, whether this problem is still in modern Zope versions.
> > Not sure, whether it is your problem...
> 
> Sounds similar, however we get it on rollback (Undo) regardless if
> the Undo succeeds or not. Errors during normal 'forward' use seem to
> abort correctly, _even after_ the connection gets in a bad state. So,
> I'm guessing that the earlier problem may have been masked by a fixup
> that we're now going around, in some way.

Further testing seems to indicate that there needs to be at least one
failed Undo attempt: after that, _any_ undo will trigger it.

Ross

_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to