The 

On Wed, 2002-03-13 at 10:05, Martijn Jacobs wrote:
> [...]
> 
> I don't know where to start, because attaching GDB doesn't make any
> sense, since you have to start zope single threaded (according to Matts
> Stability Howto) and then no crashes occur.

Actually, at least in Linux, with a recent gdb, you can attach gdb to
zope in multithread mode. Just take the "-t 1" from the command line
sugested by the StabilityHOWTO and you're set. Best results are achieved
by compiling everything from source (python even, use the
--prefix=/path/to/zope-src so as not to mix up with your installed
python and be careful to use this python when installing zope) and
running:

$ VARIABLE=value gdb path/to/your/python
(gdb) run z2.py -Z '' 

where VARIABLE=value should be replaced by the env vars that are set in
the ./start script inside Zope.

> Is this problem solved if I install python 2.2 for example? Are there
> any bugfixes in this release from Python 2.1.2 ?

No, as far as I know.

> I don't know what the status is right now? Is zope corp. working on it
> trying to find the bug? Can I be of any help tracking down this bug? 

I don't know about Zope Corp. in general, but Matt Kromer has been
trying to help as much as his time permits.

I think you're helping a lot just by reporting this problem because it
helps raise awarenes to the fact that the stability problems aren't all
solved with the last Zope/Python releases. So far there are three
confirmed cases of instability: yours, mine and Dario's. All of them
seem to involve PythonScripts, although this might not be related, and
all of them are solved by using '-t 1' (is that correct, Dario?) so it
looks like a threading issue.

Let's just hope ZC or someone else in the community with more knowledge
of the Zope/Python internal arcana can help us debug this, 'cause it's
reached the limit of our exploration capability.

Cheers, Leo


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to