I had the same problem a few weeks ago, and i posted my bug to the collector 
with a example class.

See there:
http://collector.zope.org/Zope/275

This friday, 9:00am EST there will be a "BugDay" on 
irc://irc.zope.org/#zope-dev

Description of BugDays here:
http://dev.zope.org/CVS/BugDays


I hope someone will be able to discuss this bug with me during the BugDay, 
and anyone with the same problem to be around and help.

[]'s

On Sab 06 Abr 2002 01:43, you wrote:
| I am building a python product. I am having trouble getting default
| security permissions to set.
| I am able to declare the permission properly, but the defaults dont work.
|
| I try the line
|     security = ClassSecurityInfo()
|     security.setPermissionDefault('View User Home',
|                       ['Anonymous','Authenticated'])
|     security.declareProtected('View User Home', 'home')
|
| The 'declareProtected' works, but the 'setPermissionDefault' has no effect
| on anything.
|
| I have no idea what else I need to be doing.
|
| Tom
|
|
|
|
| _______________________________________________
| Zope maillist  -  [EMAIL PROTECTED]
| http://lists.zope.org/mailman/listinfo/zope
| **   No cross posts or HTML encoding!  **
| (Related lists -
|  http://lists.zope.org/mailman/listinfo/zope-announce
|  http://lists.zope.org/mailman/listinfo/zope-dev )

-- 
Sidnei da Silva (dreamcatcher) <[EMAIL PROTECTED]>
X3ng Web Technology <http://www.x3ng.com.br>
GNU/Linux user 257852
Debian GNU/Linux 3.0 (Sid) 2.4.19-pre6-ben0 ppc

"But what we need to know is, do people want nasally-insertable computers?"



_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to