> >I'm upgrading to zope 2.6.0.
> >When I try to import a ZClass based Product from zope 2.5.1
> i get the
> >following error.
> >
> >Error Type: ImportError
> >Error Value: No module named iclass

> Yup.  This was discussed about a week ago. Search the mailing
> list archives; but as I remember, only the ZClasses descended
> from ObjectManager have the problem, and then only if there
> is a non-empty list on the SubObjects tab.  To export from
> 2.5.x, remove all from that list; then it will import fine
> into 2.6.  Then, I presume that you can recreate the list of
> allowed subobjects, though I have not tried this.

This worked fine.


I'm having the same problem migrating a zclass from 2.5.1 to 2.6.
I've tryed the collector fix of ZClasses/ObjectManager.py and the subobjects tab thing, but
that didnt solved my problem.

My zclass has ZFolder as base class instead of ObjectManager:

Base Classes: ZObject, ZFolder, CatalogAwareBase

I'm looking at the ObjectManager.py to see if I can put it to work for my zclass, but
I think in my case that doesnt make sense because my class dont have a subobject tab...

I'm looking into the zen of iclass...

Any ideias? thanks.

Julio Silva

I'm forwarding this mail to zope-dev because since this is related with 2.6.0 development changes
against 2.5.1 maybe someone has other solutions, because the that is out there for ObjectManager
doesnt solve my problem.

Best Regards,
Julio Silva
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.416 / Virus Database: 232 - Release Date: 11/6/2002

Reply via email to