Fred L. Drake, Jr. wrote:
Chris Withers writes:
 > Will I have to change the way Zope is built and/or the etsts are run?


> If so, where could I find otu what they now need to look like?

There is a <scenario> for Linux in the newinstallbranch.xml in
Packages/TestScripts; I'll test it again before the merge takes
place. doesn't appear to work on Windows, since VC++ doesn't provide 'make'.

I don't know about the Windows <scenario>, but it's probably OK for
now.  It may need to change in the future (I'll try to help as much as
possible; Tim just tried the new-install-branch tests on Windows and
we found one buglet there).  I won't be in front of a Windows box
myself until tonight.

Well, I tried subbing 'nmake' for 'make' in the Linux scenario, and got this:

cvs export: Updating Zope/var
U Zope/var/.cvsignore
U Zope/var/
Running: c:\python22\python -c "import sys; print sys.version"
Running: configure
Running: nmake build
'configure' is not recognized as an internal or external command,
operable program or batch file.

Microsoft (R) Program Maintenance Utility Version 6.00.8168.0 Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

NMAKE : fatal error U1073: don't know how to make 'build'

I'm guessing that the real culprit here is 'configure' not working.
How did Tim get it to work?



PS: For safety's sake, I'll disable the Zope HEAD tests tonight, pendign this isssue being resolved...

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to