i've posted this to zope list, and got hints from dieter about the 
toby-clean-shutdown branch.

i apologize if this is not appropriate.
i'm restating the question again:

since upgrading zope from 2.5.1 + zeo1, i've been having frequent zope/zeo 
client hanging/not responding.

the setup:
we have zope-2.6.1-src + zeo-2.0.2 on linux with python 2.1.3

frequently, the zeo client hangs/not responding. output of ps axf is below[1] 
and the stupid.log[2] 

i've setup stupid_log_severity=-100 fr ZEO_EVENTS.log, and the last 20 lines 
of the log is attached.  this is when all zeo clients failed to get to the 

restarting the zeoserver makes things peachy again
also, sometimes i got this error[4] in ZEO_EVENTS.log.

telnet localhost 8080
GET / HTTP/1.0\n\n
resulted in nothing.  no time out, nothing

running ./stop will only kill the parent process, i.e 17160 in the below 
example.  the other processes can only be killed with a kill -9 17161.

restarting the zeoclient will make it respond again.

i've tried zeo2.1a1( iirc) and the behaviour is the same
i used to run with persistent zeo cache (ZEO_CLIENT=12000) in the ENV, but 
running without is still the same.  i've also tried runnin with -Z1, and -Z-
also the same behaviour

thanks for any help/pointers
ps axf [1]
# ps axf|grep py
17560 pts/0    D      0:00          \_ grep py
17160 ?        SW     0:00 /usr/bin/python2.1 /usr/local/Zope-2.6.1-src/z2.py 
17161 ?        S     16:39  \_ /usr/bin/python2.1 
17162 ?        S      0:00      \_ /usr/bin/python2.1 
17165 ?        R     26:09          \_ /usr/bin/python2.1 
17166 ?        S     28:26          \_ /usr/bin/python2.1 
17167 ?        S     26:50          \_ /usr/bin/python2.1 
17168 ?        S     27:11          \_ /usr/bin/python2.1 

[2]# tail var/stupid.log
2003-03-21T10:24:53 BLATHER(-100) zrpc-conn: calling 
Invalidate([('\x00\x00\x00\x00\x01\x0bQ\xec', ''), ('\x00\x00\x00\x00\...
2003-03-21T10:25:20 BLATHER(-100) zrpc-conn: calling 
Invalidate([('\x00\x00\x00\x00\x00\x00$\xae', ''), ('\x00\x00\x00\x00\...
2003-03-21T10:25:28 BLATHER(-100) zrpc-conn: calling 
Invalidate([('\x00\x00\x00\x00\x00\x1c\x9a\xd9', ''), ('\x00\x00\x00\x...
2003-03-21T10:25:50 BLATHER(-100) zrpc-conn: calling 
Invalidate([('\x00\x00\x00\x00\x01\x0bQ\xea', ''), ('\x00\x00\x00\x00\...
2003-03-21T10:25:53 BLATHER(-100) zrpc-conn: calling 
Invalidate([('\x00\x00\x00\x00\x01\x0bQ\xea', ''), ('\x00\x00\x00\x00\...

[3]# tail -20 ZEO_EVENTS.log.1
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x01![\xf6', '\x03K\xc4\x88\x17b\xc7\xbb',...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x01*Of', '\x03K\xc4\x88\x17b\xc7\xbb', '(...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x01*N\xea', '\x03K\xc4\x88\x17b\xc7\xbb',...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x01*N\xeb', '\x03K\xc4\x88\x17b\xc7\xbb',...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x01!Z\n', '\x03K\xc4\x88\x17b\xc7\xbb', '...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
storea('\x00\x00\x00\x00\x00\xb0_\xfd', '\x03K\xc4\x88\x17b\xc7\xb...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
2003-03-24T03:20:07 INFO(0) ZSS:15977/ Transaction blocked 
waiting for storage. Clients waiting: 3.
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 
tpc_begin('\x03K\xc4\x89\xc2\xa9-\x88', ' None', '/Poll/BHQ5/processV...
2003-03-24T03:20:07 BLATHER(-100) zrpc-conn: calling 

2003-03-24T09:28:16 ERROR(200) Conflict Resolution Unexpected error
Traceback (innermost last):
  File /usr/local/Zope-2.6.1-src/lib/python/ZODB/ConflictResolution.py, line 
96, in tryToResolveConflict
    (Object: /usr/local/ZopeHome/var/Data.fs)
SystemError: Failed to import class ClassicHTMLFile from module 

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to