Severals day ago I send that letter to Jim. May be it was bad idea, and Jim
dont answer me anything.

But problem still exists.

Can you take me some advise how (and is that possible?) commit this patch to
Zope 2.7 release?
Who can do it?

----- Original Message -----
From: "Mikhail Kashkin" <[EMAIL PROTECTED]>
Sent: Wednesday, September 03, 2003 11:29 PM
Subject: Zope and unicode

> Hello Jim!
> Zope from 2.6 release try to support unicode, but it make big problem to
> developers who cann't use unicode (there is many reasons). We make patch
> Zope 2.7.b1, but it also work with 2.7.b2.
> What this patch do.
> 1. Now Zope think that all non-unicode types (string, text, etc) use only
> latin-1 charset. It raise error when server encode sended data on
> (manage_properties) page (I haven't now traceback, but will send uppon
> request).
> 2. "manage_properties" work only in utf-8 charset that make big problems
> set (and read) values in national encodings. "management_page_charset" not
> resolve this problem it haven't effect on "manage_properties". Patch set
> proper charset. By default it will be as active locale (-L key).
> 3. Many other bugfixes (all in description on russian).
> I'm sorry for my poor english, I would like to pay your attantion to this
> patch. If you dont consider it
> then the work with Zope for russian Zope-developers/users will be quite
> complicated.
> I attach you full description to patch on russian, may be it will bu
> for you.
> P.S.
> I submit it as bug to bugtracker under #1037
> (http://collector.zope.org/Zope/1037).

Attachment: Zope-270b1-unicode.patch
Description: Binary data

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to