I announced that, for now, The Zope head won't work with old databases.
We are going to have to come up with some code to deal with the
old btrees and intsets.

The good news is that, databases created with Zope 2.7 final should
work. :)


Jeremy Hylton wrote:
On Thu, 2003-12-11 at 10:24, Sidnei da Silva wrote:

On Thu, Dec 11, 2003 at 10:07:51AM -0500, Jeremy Hylton wrote:
| I think there's a fix for this in CVS.  Can you try it again?

Just tried. Seems to have fixed it. Now, for the next step *wink*.

If I try starting Zope with an old existing database I get the
traceback below. Correct me if I'm wrong, but I think the error with
'UserDict' has nothing to do with the 'Could not import class 'BTree''
or am I wrong?

I think the attribute error on data is just a symptom of the BTree
failure.  The object has no data attribute, because ZODB failed to
unpickle the object that would be assigned to data.

I don't know what happened with backwards compatibility for the old
BTree classes.  When Jim and I discussed it a while back, I thought we
concluded that we would provide a script that would convert all the old
BTree instances to new BTrees instance.  But I don't know if that
decision stuck or if the script was ever written.


Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to