Thanks for the response Dieter,

On 5 Feb 2004, at 18:51, Dieter Maurer wrote:

Tony McDonald wrote at 2004-2-5 12:43 +0000:
...
We have an index_html (initially DTML document, then tried method) that
can be created (located at /prototype/myporfolio/index_html), have it's
security settings changed quite happily. Then when the object is called
we get the error in the subject line. The system specs are;
...
and the traceback is;


Traceback (innermost last):
...
  Module Shared.DC.Scripts.Bindings, line 320, in
__render_with_namespace__
  Module Shared.DC.Scripts.Bindings, line 343, in _bindAndExec
  Module App.special_dtml, line 175, in _exec
  Module DocumentTemplate.DT_Util, line 201, in eval
   - __traceback_info__: RESPONSE
  Module <string>, line 0, in ?
AttributeError: 'NoneType' object has no attribute 'setHeader'


Looks like "RESPONSE" is "None".


I do not see how this can happen...


Exactly! - this is why I said I'd never seen this before.


It's a 2.6.1 Data.fs that's been dropped into a stock 2.7.0rc2 release and I get this error.

I have no idea why this is happening, so I was hoping that it was an artifact of the 2.7.0rc2 release itself.

Probably, I would start debugging.


Quite likely, but I have *no* idea where to start with this. All the modules mentioned in the trackback are Zope supplied ones, not third party ones, so I'd assumed it might be the core software.


--
Dieter

once again, thanks for the reply Dieter.


tone.
--
Dr Tony McDonald, Asst Director, FMSC. 0191 245 4223
Project Manager, FDTL-4 ePortfolios http://www.eportfolios.ac.uk/


_______________________________________________
Zope-Dev maillist - [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to