Looks like the test runner is picking up tests in the build-base
directory (which is generated as a result of make), which might also be
why it's so slow, because it's likely running every test twice.  How are
you running the tests?

FWIW, the automated test runners do the equivalent of:

./configure
make inplace
python test.py --all

- C



On Mon, 2004-02-23 at 17:24, Christian Theune wrote:
> Howdi,
> 
> I just prepared the post traversal checkin and was running the full load
> of Z2 unit tests (which are quiet slow in my oppinion right now. Took
> about 15 Min on Linux/P4 1.7GHz) and got a couple of errors that look
> like a problem with my build:
> 
> ======================================================================
> ERROR: testBigBoolean (testPythonScript.TestPythonScriptNoAq)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File
> "/home/ctheune/Development/Zope/Zope.pt/lib/python/Products/PythonScripts/tests/testPythonScript.py",
>  line 154, in testBigBoolean
>     res = self._filePS('big_boolean')()
>   File
> "/home/ctheune/Development/Zope/Zope.pt/lib/python/Products/PythonScripts/tests/testPythonScript.py",
>  line 60, in _filePS
>     ps.write(readf(fname))
>   File "testPythonScript.py", line 32, in readf
> IOError: [Errno 2] No such file or directory:
> '/home/ctheune/Development/Zope/Zope.pt/build-base/python-2.3/build-lib/Products/PythonScripts/tests/tscripts/big_boolean.ps'
> 
> 
> I created this sandbox by:
> 
> cvs co
> ./configure
> make 
> make instance
> 
> 
> Anything wrong with that? I'm way too lazy to keep a separated instance
> home for such sandbox work.
> 
> Cheers,
> Christian


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to