Hi

On Tue, 24 Feb 2004, Chris McDonough wrote:

> Yes, it's still broke.  No, there is no fix.  Sorry.

Thanks Cris. Thats very bad. It is very bad from end-user perspective that
such critical bug has been found more then year ago, and nobody at Zope
has fixed their code during a year time.
 
I am trying to read all the things you have discussed in March 2003, but 
it is very difficult to understand how to fix that. Also, I am in doubt I 
will be able to do that, because if Zope-experienced developers can not 
fix it, my chances are low. 

I just have no choice - we already developed a product for Zope, so I have 
to support it. Even if it requires hacking of application server itself.

I see that fix:

        #db.klass = LowConflictConnection

but it does not work for us. At least we keep seeing the session
errors with any Zope version - we tries Zope 2.6.4, Zope 2.7.0 with 
same results.

So, as far I you see, as soon as Zope starts using sessions, and when 
there are many customers, the site is dead for some users. 

Once 'get' error occurs to a specific Session, the customer is blocked
and is not able to see any page on the site: all pages produce this get 
error. 

That is very critital and 'blocker' bug for Zope. I do not understand how
people could use Zope on a sites with high load..

The only thing which works is asking customer  to delete all Cookies, so 
session ends, and new one starts. This is very ugly fix, you understand...

I am not Zope hacker itself, we are just building sites, we are not 
developers of Server solutions in most of time, so it takes time to study 
the Zope code to be able to fix that...

I will try to work on this more and more, but ... Its just very difficult. 

Anybody, experienced with Zope developmnet could help me? I am sure, this 
problem could happend to anyone running a big Zope site. Is anybody
interested in helping to resolve this blocker Zope+Sessions issue?

As soon as you start getting more hits to any Zope based site, the more 
customers will not see it because of Session problem. 

I do not know how many customers of our site getting this, but we do 
get it everyday several times a day / person. So, in my understanding Zope 
Session is completely broken. It works fine for a several customers/ hour, 
but when things come to 1000 visits/ hour, it just stops functionaning 
properly. 

I will be trying to study Zope code.... That is what Open Source for, and
I am a big fun of that. But of course, it does not help much if you are 
not experienced with product itself. It takes time to learn it.

But I will try. If anybody interested in help, it would be great. at the
current moment I am trying to stable reproduce the prob, but it 
seems it only happends on a site with high load.


--
Alex V. Koval
http://www.halogen-dg.com/
http://www.zwarehouse.org/



> 
> - C
> 
> 
> On Tue, 2004-02-24 at 11:43, [EMAIL PROTECTED] wrote:
> > I see Chris post at:
> > 
> > http://mail.zope.org/pipermail/zope-dev/2003-March/019116.html
> > 
> > As far I see, this bug still existing in Zope 2.6.4, Zope 2.7.0.
> > 
> > Its strange because into Changes histore of Zope it seems to be fixed 
> > into 2.6.2:
> > 
> >  Zope 2.6.2 beta 2
> > Bugs Fixed
> > 
> >     * TemporaryStorage (which is used by TemporaryFolder, and thus the 
> > default sessioning configuration) no longer uses a "LowConflictConnection" 
> > database connection. This fixes a bug in which data structures used for 
> > session housekeeping data could become desynchronized; the symptom for 
> > this was KeyErrors being raised from TransientObjectContainer's get 
> > method. As a result, many more conflicts will be raised under high session 
> > load, but desynchronization will not occur.
> > 
> > Could you please at least point me where I can dig to get it fixed?
> > I will try to read Python code in Transience.Transience but I am not sure
> > in my qualification in this area.
> > 
> > Bug reported at zope.org as: http://zope.org/Collectors/Zope/848 but until
> > now there were no comments which help me to fix this.
> > 
> > may be something needs to be changed into my code? in the beginning
> > of many scripts I have the following:
> > 
> > request=container.REQUEST
> > session=request.SESSION
> > 
> > please give me a hint.
> > 
> > Thanks.
> > 
> > --
> > Alex V. Koval
> > http://www.halogen-dg.com/
> > http://www.zwarehouse.org/
> > 
> > 
> > _______________________________________________
> > Zope-Dev maillist  -  [EMAIL PROTECTED]
> > http://mail.zope.org/mailman/listinfo/zope-dev
> > **  No cross posts or HTML encoding!  **
> > (Related lists - 
> >  http://mail.zope.org/mailman/listinfo/zope-announce
> >  http://mail.zope.org/mailman/listinfo/zope )
> 
> 


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to