That sounds possible. I added support of Python 2.3 datetime, and while I tried to handle alternate timezones correctly I may have failed. I'll try to look at this later today.


Tres Seaver wrote:
Christian Theune wrote:


I address you directly because I haven't received feedback on this from
the zope-dev mailinglist and you have been the last ones touching code
in Products/DateIndex.

This test is breaking for me but not on Jeremys daily tests for Zope 2
on the HEAD:

FAIL: test_retrieval
Traceback (most recent call last):
"/home/ctheune/Development/Zope/Zope/lib/python/Products/PluginIndexes/DateIndex/tests/", line 184, in test_retrieval
self.failUnlessEqual(len(index), len(values) - 2) # One dupe, one
File "/usr/lib/python2.3/", line 302, in failUnlessEqual
raise self.failureException, \
AssertionError: 8 != 9


I tried debugging that but I don't know the internal interfaces of the
PluginIndexes well enough to not waste time.

I don't know which special information you could need. I'm running
pretty everything standard (python 2.3, linux with 2.6.3 kernel).

The Sandbox was compiled by:

  make instance

The test was run by


This test is the only one that breaks and keeps me from checkin in
several changes for quite a while already.

That test isn't broken for me on the HEAD. At a guess, I would bet that some change (re)introduced a sensitivity to timezones within the test; can you try running the test in an environment where the timezone is GMT? GMT-1? I think you are in GMT+1 land, right?


Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to