Hi!


Fred Drake wrote:
On Thursday 11 March 2004 10:40 am, Tres Seaver wrote:
 > #!/usr/bin/python2.3
 >
 > distutils will munge it anyway, if it installs the scripts.

That won't work for a lot of developers, I'll bet, who have python2.3 installed in /usr/local/bin. The "env hack" is more reasonable for developers; since distutils is going to munge the sh-bang line anyway, it's not an issue for real installations.

I don't care much *how* this is resolved, but I'd like to have this consistent and up to date. If I always have to check if the python version is set correctly that line isn't helpful at all.


If we can get any consensus on this question I'll volunteer to check in the changes.


Cheers, Yuppie



_______________________________________________
Zope-Dev maillist - [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to