On Friday 16 April 2004 01:31 pm, Michael Bernstein wrote: > From a consistency in nomenclature POV, I find 'z' jars a bit with > ZConfig, zdaemon, ZEO, zLog, and ZODB, which one might expect to find > nested within 'z' (as 'z.Config' for example). This is admittedly only > an issue for the newest newbies still trying to guess at where stuff is > located.
I don't know what zLog is; presumably you mean zLOG?
zLOG is dead in Zope 2.8, and will remain only for API compatibility.
I don't think there's any real consistency now for what's in the Zope 2 head, so I don't think that's a big deal.
Shouldn't we strive for consistency in nomenclature going forward?
> However, rather than suggest a wholesale moving and renaming of these > packages within 'z', I'd like to suggest an alternative short name for > the 'zope' package, 'OPE', which avoids this issue: > > import OPE.interface > from OPE.app import zapi > from OPE.app.event import publish > from OPE.app.event.objectevent import ObjectModifiedEvent
(I do hope you're joking!)
About even considering a 'wholesale moving and renaming' yes, obviously, but as far as suggesting 'OPE' as an alternative to 'z' (insofar as it is still necessary to avoid a name-clash with 'Zope'), no. 'OPE' (as an acronym for Object Publishing Environment) seems like it fits better conceptually than 'z'.
Did I miss something? Did I just manage to embarrass myself? Is this a dream where I find I am wearing nothing but underwear in public and then wake up?
-- - Michael R. Bernstein michaelbernstein.com Author of Zope Bible
Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce