Fixed for 2.7.1b2.

-aj

--On Montag, 31. Mai 2004 21:31 Uhr +0200 Stefane Fermigier <[EMAIL PROTECTED]> wrote:

Testing CPSCore: make: *** [test] Error 1 (
handlers.handleConfig(opts.configroot, opts.confighandlers))
Here is the full log:
-------------------------------------------------------------------------
-----
Loading Zope, please stand by ...Traceback (most recent call last):
   File "runalltests.py", line 24, in ?
     m = __import__(test)
   File "test_base.py", line 23, in ?
     import Testing.ZopeTestCase.ZopeLite as Zope
   File
"/home/fermigier/cvsnuxeo/tools/publication/Zope/lib/python/Testing/ZopeT
estCase/__init__.py", line 7, in ?
     import ZopeLite as Zope
   File
"/home/fermigier/cvsnuxeo/tools/publication/Zope/lib/python/Testing/ZopeT
estCase/ZopeLite.py", line 105, in ?
     _theApp = Zope.app()
   File
"/home/fermigier/cvsnuxeo/tools/publication/Zope/lib/python/Zope/__init__
.py", line 53, in app
     configure()
   File
"/home/fermigier/cvsnuxeo/tools/publication/Zope/lib/python/Zope/Startup/
run.py", line 30, in configure
     opts = _setconfig(configfile)
   File
"/home/fermigier/cvsnuxeo/tools/publication/Zope/lib/python/Zope/Startup/
run.py", line 47, in _setconfig
     handlers.handleConfig(opts.configroot, opts.confighandlers)
AttributeError: ZopeOptions instance has no attribute 'confighandlers'
make: *** [test] Error 1


All the CPS tests pass under Zope 2.6.1, 2.6.4 and 2.7.0.

Any idea of what's going on ? Could it be a problem with ZopeTestCase
(I'm using ZTC 0.9.0) ?

S.





_______________________________________________
Zope-Dev maillist - [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to