Martijn Faassen wrote:
Hi there,

I recall discussion but no conclusion: what is the status of the case-conflict between the "Zope" package in Zope 2 versus the "zope" package in Zope 3?

I chose alternative 4 from:

As that seemed to be the most popular, although I personnally
prefer 3.

Resolving this peacefully is becoming more urgent for me as I'd like to be able to use Five (Zope 3 on Zope 2) on Windows eventually. >

Is there some workaround?

Sure, put "zope" in a different directory.

> I'd really hate to have to wait for a mythical
Zope 2 release (likely not 2.8) that renamed Zope to something else, for instance.

I had planned to do this in Zope 2.8, mainly because I wanted to include zope.interface in 2.8, mainly to address the difficulty of installing the Interface shim. Your recent work makes the shim unnecessary. I'm really anxious to get 2.8 out, so I'm inclined not to include zope.interface in 2.8, and thus not deal with the zope vs Zope issue in 2.8.


Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714  
Zope Corporation

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to