I have finally realized that the way tests are run in 2.7 is different from earlier version of Zope, and I'm trying to get them to run.

It's Zope 2.7.2 on Debian. Python 2.3.4 and 2.3.2, so I guess 2.3.3 would give the same error. Could it be a side effect of the compiling or something?

Here is the traceback:

Running unit tests from /home/regebro/Zopes/Zope-2.7.2-0
/home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/cDocumentTemplate.so: undefined symbol: PyUnicodeUCS4_DecodeLatin1
['/home/regebro/Zopes/Zope-2.7.2-0/lib/python', '/home/regebro/Zopes/Zope-2.7.2-0', '/usr/local/lib/python23.zip', '/usr/local/lib/python2.3', '/usr/local/lib/python2.3/plat-linux2', '/usr/local/lib/python2.3/lib-tk', '/usr/local/lib/python2.3/lib-dynload', '/usr/local/lib/python2.3/site-packages']
Traceback (most recent call last):
File "test.py", line 841, in ?
File "test.py", line 831, in process_args
bad = main(module_filter, test_filter, libdir)
File "test.py", line 629, in main
files = find_tests(module_filter)
File "test.py", line 460, in find_tests
os.path.walk(walkdir, finder.visit, rx)
File "/usr/local/lib/python2.3/posixpath.py", line 290, in walk
walk(name, func, arg)
File "/usr/local/lib/python2.3/posixpath.py", line 290, in walk
walk(name, func, arg)
File "/usr/local/lib/python2.3/posixpath.py", line 282, in walk
func(arg, top, names)
File "test.py", line 439, in visit
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/AccessControl/__init__.py", line 16, in ?
import DTML
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/AccessControl/DTML.py", line 18, in ?
from DocumentTemplate import DT_Util
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/__init__.py", line 22, in ?
from DocumentTemplate import String, File, HTML, HTMLDefault, HTMLFile
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/DocumentTemplate.py", line 112, in ?
from DT_String import String, File
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/DT_String.py", line 17, in ?
from DT_Util import ParseError, InstanceDict, TemplateDict, render_blocks, str
File "/home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/DT_Util.py", line 42, in ?
from cDocumentTemplate import InstanceDict, TemplateDict, \
ImportError: /home/regebro/Zopes/Zope-2.7.2-0/lib/python/DocumentTemplate/cDocumentTemplate.so: undefined symbol: PyUnicodeUCS4_DecodeLatin1

Any ideas why this is? The Zope in itself seems to work fine. I have a 2.7.0 instance to, it also fails, but with a completely different error.


Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to