On 29/09/2004, at 11:07 AM, Matteo Memelli wrote:

Hello I include the conversation that I had today with Chris:

I'm using Zope 2.6b1+ with ZWarehouse e-commerce product
(ZWarehouse-20040522 version 0.8)
I tried upgrading to Zope 2.7 but ZWarehouse gave me many problems so
I decided to try applying your patches for Sessioning problems that I
have.

Hmm..

I think that the error that zope gives to me is very known to you... I
tried to copy the whole directories Transience, Session and ZPublisher
from both
Zope-2.7.3b1-0 and Zope 2.7.2 but without success I also copied the
file startup.py from lib/python/Zope/App/ ...
Am I missing anything?

Yes, the ZODB directory also... although I reallly have no idea whether this will work under 2.6.

Really, to be sure you've got all the right files, it'd be best if you
could upgrade to 2.7.3... maybe we could help fix whatever in ZWarehouse
doesn't work under there (move this conversation to the Zope list
[EMAIL PROTECTED])


To be thorough, you will also need to delete and recreate any persistent
session data container you've got laying around (unless it's in
temp_folder, that's in RAM anyway and gets recreated on reboot).


My customer is complaining so much and I really don't know what to do!
Hoping in your answer...thank you in advance

Matteo Memelli



Site Error
An error was encountered while
publishing this resource.

KeyError

Sorry, a site error occurred.

Traceback (innermost last):

      * Module ZPublisher.Publish,
        line 175, in
        publish_module_standard
      * Module Products.iHotfix,
        line 83, in new_publish
      * Module ZPublisher.Publish,
        line 132, in publish
      * Module Zope.App.startup,
        line 203, in
        zpublisher_exception_hook
      * Module ZPublisher.Publish,
        line 101, in publish
      * Module ZPublisher.mapply,
        line 88, in mapply
      * Module ZPublisher.Publish,
        line 39, in call_object
      * Module OFS.DTMLDocument,
        line 128, in __call__
        <DTMLDocument instance at
        41725260>
        URL:
        http://www.arte-luce.com/catalog/html/catalog.html/manage_main
        Physical
        Path:/arteluce/catalog/html/catalog.html
      * Module
        DocumentTemplate.DT_String,
        line 474, in __call__
      * Module
        DocumentTemplate.DT_Let,
        line 76, in render
      * Module OFS.DTMLDocument,
        line 121, in __call__
        <DTMLDocument instance at
        4172b6b0>
        URL:

http://www.arte-luce.com/catalog/html/zwarehouse_html_header/ manage_main
        Physical
        Path:/arteluce/catalog/html/zwarehouse_html_header
      * Module
        DocumentTemplate.DT_String,
        line 474, in __call__
      * Module
        DocumentTemplate.DT_Util,
        line 201, in eval
        __traceback_info__:
        cart_functions
      * Module <string>, line 1, in
        <expression>
      * Module
        Shared.DC.Scripts.Bindings,
        line 306, in __call__
      * Module
        Shared.DC.Scripts.Bindings,
        line 343, in _bindAndExec
      * Module
        Products.PythonScripts.PythonScript, line 318, in _exec
      * Module None, line 16, in
        setSessionByRequest.py
        <PythonScript at
        /arteluce/catalog/cart_functions/setSessionByRequest.py>
        Line 16
      * Module
        ZPublisher.HTTPRequest,
        line 1218, in __getattr__
      * Module
        ZPublisher.HTTPRequest,
        line 1178, in get
      * Module
        Products.Sessions.SessionDataManager, line 94, in
getSessionData
      * Module
        Products.Sessions.SessionDataManager, line 181, in
_getSessionDataObject
      * Module
        Products.Transience.Transience, line 847, in new_or_existing
      * Module
        Products.Transience.Transience, line 450, in __setitem__
KeyError: 1096365080 (Also, an
error occurred while attempting to
render the standard error message.)


___________________________________

Troubleshooting Suggestions

      * The URL may be incorrect.
      * The parameters passed to
        this resource may be
        incorrect.
      * A resource that this
        resource relies on may be
        encountering an error.
For more detailed information about
the error, please refer to error
log.

If the error persists please
contact the site maintainer. Thank
you for your patience.




Hmmm.. that's an odd place to get that error. I'm surprised. Does it only happen after some period of inactivity on the site?

- C


FOLLOWING Chris's advice first I tried to copy also ZODB directory from Zope 2.7.3 but still the same error... so I Installed Zope-2.7.3b1-0 (IS THIS THE RIGHT VERSION THAT SHOULD SOLVE SESSION PROBLEMS?) and reinstalled with success the following packages: ZWarehouse 0.8 iHotfix-0.4.0 itools-0.4.6 Localizer-1.1.0a4 ZMySQLDA-2.0.8 MySQL-python-1.0.0 TranslationService-0.4

THEN imported my customer's web site but I still have the same
problem... whats going on... what am i missing?
For every change I made I delete and recreate any persistent
session data container rebooting the server (IS THIS ENOUGH OR MUST I DO
ANYTHING ELSE???)
From what I can see it seems that the problem comes after about 20
minutes of inactivity... session timeout? (How can I get the session
longer just for now I mean??!! modyfing default value in
session_timeout_minutes in lib/python/Zope/Startup/handlers.py ???)

Hoping to solve the problem quickly....my customer is going to kill me
otherwise :(

Hmm - my first guess is that there is something wrong with transaction handling somewhere. A significant quota of such KeyErrors in transience prior to 2.7.3 seem to be the result of incorrect transaction handling. Maybe in one of the above products? If it is something with transaction handling then might get some pain relief by running on one ZODB thread.


michael

_______________________________________________
Zope-Dev maillist - [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to