Tres Seaver wrote:

Are you sure that you have applied whatever patch is required to give Python a big enough stack on FreeBSD (Hmm, I foresee a new spam topic, "Enlarge your Python's Stack! Make your Zope beg for mercy!" ;)

Strange crashes reproducible only on *BSD should be checked first against this one:

Yes, I've tried increasing the stack size. I think it is a platform specific problem for threads on FreeBSD/AMD64. Regardless of how large I make the stack, or how low I set the recursionlimit, python 2.3.4 cannot complete sucessfully on this platform.

I've tried bringing it up on the FreeBSD lists, but not got much of a response. Python 2.4a3 must do *something* different with threads, as it can complete on the same platform. I've tried backporting over from 2.4a3, but that doesn't do it. I think there may be extra defines set in the Makefile or configure.


Matt Hamilton                                       [EMAIL PROTECTED]
Netsight Internet Solutions, Ltd.        Business Vision on the Internet                             +44 (0)117 9090901
Web Design | Zope/Plone Development & Consulting | Co-location | Hosting

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to