Jim Fulton wrote:
Originally, I had intended not to include any Zope 3 packages until
Zope 2.9, however, Zope 2.8 has been delayed long enough that I think
it makes sense to include some parts of Zope 3 sooner.  I also want
to use some of the Zope 3 persistent code support, which depends on
zope.interface to help get ZClasses working again.  I haven't decided
which parts of Zope 3 should be included in Zope 2.8 and would like to
get input.  If you have suggestions on what to include or exclude,
please respond here or on the z3-file list, where I am also posting
this message.

Zope 2.8 should be shipped with all stuff required for Five + some nice gimmicks like the import* helpers from utilities/.

zope.interface - Zope3 interfaces are much better than the zope2 stuff
zope.component - important for five
zope.i18n + zope.i18nmessage - especially the l10n is very useful, also gotcha is working on a way to translate MessageIds in Zope2's ZPublisher. See PlacelessTranslationService Z3MsgId branch (I can't remember the excact name)
zope.configuration - zcml is nice
zope.importtool - for importtool and importorder, please also include importchecker in ZOPE_HOME/bin. I like it :)

These modules are easy to add w/o shipping Zope2 with a full installation of Zope3. Much harder but even useful are modules from zope.app like adapter, apidoc, event or the widget stuff for zope.schema.

Personally zope.interface and zope.component are the most important and also useful thing I would like to see in Zope2.


Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to