Sidnei da Silva wrote:
On Mon, Jan 31, 2005 at 10:53:01AM -0500, Jim Fulton wrote:
<snip>
| I haven't decided
| which parts of Zope 3 should be included in Zope 2.8 and would like to
| get input.  If you have suggestions on what to include or exclude,
| please respond here or on the z3-file list, where I am also posting
| this message.

Whatever we have in Five right now seems like a good subset. I haven't
felt need for much more than that anyways. We have:

- Adapters
- Views
- Menus
- Some support for auto-generated forms

I think the main outstanding issue is interoperability between Zope 3
and Zope 2 Page Templates, which is being investigated.

Someone correct me if I missed something.

But Five has no *need* of this stuff in Zope 2, and I suspect it'll only make our life harder. Either we'll be locked into a stale Zope 2.8 version or we'll have to maintain compatibility with both Zope 3 releases and Zope 2 releases..


If someone can package up the stuff needed for Five and nothing else and wrap it up as a Zope 2 product (that fiddles with the path), fine. That's only to make things more easily deployable. Right now the hard part is however detaching Zope 3 stuff from its dependencies -- for Five you'd need an enormous chunk of Zope 3 in order to make it work. Why bother with it?

Regards,

Martijn
_______________________________________________
Zope-Dev maillist - Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to