[Eric Brun]
|> Houston, we've got big a problem !
>
> Here is the traceback in ZEO_EVENTS.log:
> ...
> CorruptedDataError: 968647571
> "
>
> And I can't pack the zodb, ...

Packing is the last thing you should be trying when you have
corruption.  There's no mechanical, safe way to recover.  Please read
this:

    http://zope.org/Wikis/ZODB/FileStorageBackup

and start by using fstest, then fsrefs, as described there.

> I run  Zope 2.6.2 , ZEO 2 and ZODB 3.1

Just noting that it's harder to get help with old releases.

> I have tried to do a fsrecover, it removes a transaction. Then when I tried 
> to lunch
> a pack,

Packing isn't an error recovery procedure.

> I've got a very strange error about unpickling :

That suggests object pickles are corrupt too; fstest can't discover
that, and fsrecover can't repair that.  fsrefs _may_ (or may not) be
provoked into complaining, or even crashing, by it.

> "Error unpickling, ((UBTrees._IIBTreeqU... [lots of gibberish] ...
>
> I try to copyTransaction in a new Storage but it failed too.

This is a surprise <wink>?  Seriously, "garbage in, garbage out"
applies here.  The garbage has to be repaired first.

> This is a production site.
> My last backup which is not corrupted date of Sunday morning !

Since fsrecover didn't work for you, you need to learn more about the
nature of the damage.  fstest, fsrefs, and fsdump are the basic tools
to start figuring that out.
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to