If there are no sane <wink> objections, I'd like to move Zope trunk to
using ZODB 3.5 tomorrow (Friday).  Zope3 has been using ZODB 3.5 for
months, and the intent has been that the ZODB 3.4 line survive for the
sake of the Zope 2.8 line (as the ZODB 3.2 line survives for the sake
of the Zope 2.7 line).  Having Zope 2.9 and Zope3 use the same ZODB
version should make sharing of Zope code across versions easier, allow
2.9 to exploit new ZODB features, and enable both Zopes to use the
same, new zpkg-based build mechanisms.

A related changed would happen soon after (probably also on Friday): 
the ExtensionClass-based Persistence package still lives in the ZODB
part of the repository, despite that it can't even be compiled from a
ZODB checkout (the prerequisite ExtensionClass implementation lives in
the Zope part of the repository).  So the plan there is to remove the
svn:externals stitching Persistence into Zope from ZODB, and move the
Persistence package from ZODB trunk to Zope trunk.  In all, this one
is just minor fiddling, but sane objections to this are welcome too.
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to