Tim Peters wrote:
I think it's worse, but mostly because a key with name "name" is also
an option in _related_ sections, but with unrelated meaning.  For
example, if you had a nested <zeoclient> section there it could also
have specified a "name" key, which would have nothing to do with the
<zodb> key named "name".  Nesting options with the same name gets
confusing quickly.  OTOH, I would like the explicit key better if it
had a different name, say

    <zodb>
      multidb-name main
      <filestorage>
        path $DATADIR/Data.fs
      </filestorage>
    </zodb>
    <zodb>
      multidb-name a
      <filestorage>
        path $DATADIR/A.fs
      </filestorage>
    </zodb>

Yes, please. There is already confusion for cache-size, let's not repeat that with another key. Note that "database-name" is more expressive, I think (the "multi" seems like an implementation detail to me).

Florent

--
Florent Guillaume, Nuxeo (Paris, France)   CTO, Director of R&D
+33 1 40 33 71 59   http://nuxeo.com   [EMAIL PROTECTED]
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to