Tim Peters wrote:
I think it's worse, but mostly because a key with name "name" is also
an option in _related_ sections, but with unrelated meaning. For
example, if you had a nested <zeoclient> section there it could also
have specified a "name" key, which would have nothing to do with the
<zodb> key named "name". Nesting options with the same name gets
confusing quickly. OTOH, I would like the explicit key better if it
had a different name, say
Yes, please. There is already confusion for cache-size, let's not repeat
that with another key. Note that "database-name" is more expressive,
Since the name of the corresponding DB argument is "database_name",
and all the docs that exist for this call it "database_name" too,
that's hard to argue against ;-)
(the "multi" seems like an implementation detail to me).
Not really: a DB's database_name was introduced specifically for the
new-in-ZODB-3.5 multidatabase feature, and has no meaning or use apart
from its multidatabase role. That's better explained in the ZConfig
<description> section for the key than in the name of the key, though.
If Jim doesn't object soon, I'll proceed with adding a database-name
key to ZODB's config.
Jim Fulton mailto:[EMAIL PROTECTED] Python Powered!
CTO (540) 361-1714 http://www.python.org
Zope Corporation http://www.zope.com http://www.zope.org
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -