[Tim]
>> I opened a Collector issue on this about a month ago (I always run
>> with `--all`, so these failures are old news to me):
>>
>>     http://www.zope.org/Collectors/Zope/1947

[Philipp]
> Rereading that issue again, it's totally surprising to see that there's no 
> failure on
> Windows, which makes its source even harder to debug.

No, these tests fail on Windows too.  In fact, the problem was
orginally reported against Windows:  see entry #2 in:

    http://www.zope.org/Collectors/Zope/1931

What does not fail on Windows is the specific variation you asked me
to try in your comment #2 on issue 1947:

    When you run it by itself, it passes, though. Maybe you can confirm that.

In my comment #3 on issue 1947, I confirmed that:  when I ran the
functional.txt test _by itself_ on Windows, it passed.

> I wouldn't know where to start (having tried to debug this problem in the 
> past).
> Anyone got an idea?

For a start, disabuse yourself of the illusion that it acts
differently on Windows than on Linux ;-)
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to