yuppie wrote at 2007-2-3 11:44 +0100:
> ...
>Unfortunately integrating a product into the Zope core means more than 
>just adjusting the coding style:
>
>- As already mentioned in this thread, monkey patches and code like 
>fixPluginIndexes.py have to be resolved. AdvancedQuery contains a monkey 
>patch for CMF - that should not be shipped with Zope core.

"fixPluginIndexes" fixed (maybe meanwhile resolved) bugs in
"Products.PluginIndexes.common.util.parseIndexRequest".

The mentioned CMF monkey patch gives the "CatalogTool" the new method
"evalAdvancedQuery", provided CMFCore is installed.
I do not see why this monkey patch should not be applied.

I am sure that I want to be able to use "AdvancedQuery" even
with a "CatalogTool", if both are installed.



-- 
Dieter
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to