-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jens Vagelpohl wrote:
> 
> On 12 Apr 2007, at 13:35, Miles wrote:
>>> However, having logged this, the testrunner proceeded to run all my  
>>> tests correctly, and so the buildbot reported a pass.  I expected  
>>> the testrunner to bomb out on encountering this error, but it  
>>> didn't - however if I start zope with zopectl fg, the bug I  
>>> introduced causes it to fail to start.
>>>
>>> I'm a bit concerned that there was a false test pass.  Is there a  
>>> way to stop the testrunner in this case, in the same way as running  
>>> in fg mode?
> 
> If I remember correctly the startup success/failure with a defective  
> product present is governed by debug mode. If you turn it on in  
> zope.conf and attempt to start Zope via "zopectl start" it should  
> fail as desired. "zopectl fg" forces debug mode to be switched on.

Correct.  The reason the OP's tests are passing is likely that they are
real unit tests, and therefore don't depend on having the product's
'initialize' method run (if they did, they would be *integration* or
*functional* tests).


Tres.
- --
===================================================================
Tres Seaver          +1 540-429-0999          [EMAIL PROTECTED]
Palladion Software   "Excellence by Design"    http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGHkR9+gerLs4ltQ4RAng/AJ41pLpp8Ro89oxpkdCcSmtAC/9CvQCgnEzL
6jt0KI9fah8uPiJum901HD8=
=ZpeV
-----END PGP SIGNATURE-----
_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to