On Nov 16, 2007, at 9:14 AM, Martin Aspeli wrote:

On Nov 16, 2007 2:07 PM, Stephan Richter <[EMAIL PROTECTED] > wrote:
On Thursday 15 November 2007, Martin Aspeli wrote:
Then I tried to easy_install zope.security, but this pulled in most of Zope, including the ZODB, ZConfig and zdaemon. That's a real shame - no CA (at least not with ZCML) without having pretty much all of Zope there.
:(

Actually, I never got to try it further, because this then died with:

Installed
/Users/optilude/Development/Pylons/zylons/lib/python2.4/site- packages/ZConf
ig-2.5-py2.4.egg error: Installed distribution zope.traversing 3.4.0
conflicts with requirement zope.traversing>=3.5.0a1.dev-r78730

Are the Zope eggs ready for prime time? Maybe I should be doing it
differently?

You need to specify the KGS for all downloads, then you would not have gotten
the conflict.

I may have screwed it up (it was late), but I used -i <kgs_url> for
each invocation of easy_install.

Unless there's some failure mode I haven't seen with the same symptom, somehow your easy_install process managed to find a distribution of zope.app.publisher 3.5.0a2 (which only exists AFAIK on the cheeseshop) that has a dependency on zope.traversing>=3.5.0a1.dev-r78730 instead of zope.app.publisher 3.4.1, which does not.

I just tried to do "bin/easy_install --index-url=http://download.zope.org/zope3.4 zope.security" in a clean virtualenv and it worked for me, so I suspect you might have missed typing the --index-url once. You might just blow everything away and try it again.

- C

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to