On Nov 26, 2007, at 2:28 PM, Philipp von Weitershausen wrote:

Christophe Combelles wrote:
An full-egg zope 3.4 buildout installed with zopeproject tells me the zope
version is 3.3.1 (in /++etc++process/):
- I have a fully eggified zope 3.4 installed with zopeproject.
- I also have a zope 3.3.1 installed on the system python.
When I start the 3.4 full-egg instance, I've discovered that
zope.app.applicationcontrol.zopeversion tries to reach zope/app/ version.txt
to determine the major zope version.
Since version.txt does not seem to be included in any egg, it fallbacks to the system zope installed.

"system zope"? It seems like you have a globally available Zope installation. This will obviously confuse any *local* sandbox, such as the one created with zopeproject. Make sure you don't have any Zope libraries on your standard PYTHONPATH.

Wouldn't it make sense if zopeproject didn't include system python
in PYTHONPATH at all?

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to