On 24 Dec 2007, at 16:32 , Andreas Jung wrote:
WARN: KGS incomplete - zope.app.content_types not found
WARN: KGS incomplete - zope.app.event not found
WARN: KGS incomplete - zope.app.filerepresentation not found
WARN: KGS incomplete - zope.app.location not found
WARN: KGS incomplete - zope.app.mail not found
WARN: KGS incomplete - zope.app.rdb not found
WARN: KGS incomplete - zope.app.servicenames not found
WARN: KGS incomplete - zope.app.site not found
WARN: KGS incomplete - zope.app.size not found
WARN: KGS incomplete - zope.app.tests not found

I kicked them.

Well, they've been deprecated for a while but it says they were scheduled for removal in Zope 3.5 which corresponds Zope 2.12. So we can't get rid of them just yet. Zope 2.11 shoudl still contain them.

IMO it's fine to simply leave the externals from the 2.10 branch for them in place.

I created a test branch and adjusted the externals so far.

zope.thread seems to be a broken (there is no _zope_thread.c
file)...however had no time for further investigations.

As Tres pointed out, the C extension is gone, so you can just remove that entry from setup.py.

And the testrunner produces 9 errors...anyone with a fast idea about
the reasons for the failures (before doing further investigations)?

"/opt/python-2.4.4/bin/python" "/Users/ajung_data/sandboxes/Zope/ ajung-2-11-prep-branch/test.py" -v
Running tests at level 1
Running unit tests:
rror in test testSetupConfiguredLoggers (Zope2.Startup.tests.testStarter.ZopeStarterTestCase)
Traceback (most recent call last):
File "/opt/python-2.4.4/lib/python2.4/unittest.py", line 270, in run
File "/Users/ajung_data/sandboxes/Zope/ajung-2-11-prep-branch/lib/ python/Zope2/Startup/tests/testStarter.py", line 69, in tearDown
File "/Users/ajung_data/sandboxes/Zope/ajung-2-11-prep-branch/lib/ python/ZConfig/components/logger/tests/test_logger.py", line 72, in tearDown
  assert loghandler._reopenable_handlers == []

I can say nothing about these failures. It seems like they're ZConfig- related.

Running zope.testbrowser.tests.TestBrowserLayer tests:
Tear down zope.formlib.tests.FormlibLayer in 0.005 seconds.
Set up zope.testbrowser.tests.TestBrowserLayer Traceback (most recent call last):
  ImportError: No module named session.interfaces

Running zope.traversing.tests.layer.TraversingLayer tests:
Set up zope.traversing.tests.layer.TraversingLayer Traceback (most recent call last):
ConfigurationError: ('Invalid value for', 'package', 'ImportError: Module zope has no global securitypolicy')

Those two are related to an unplanned split-up of zope.app.securitypolicy and zope.app.session. They occurred in the 3.4.x line even though they should've in the 3.5.x line. So, what you'll need to do is add externals for zope.session and zope.securitypolicy (notice the missing "app"!) according to the KGS. That should get that settled.

Thanks for tackling this, Andreas.

Merry Christmas,

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to