Products.Five.browser.adding is basically a copy of
zope.app.container.browser.adding. Over time they became more out of
sync than necessary. I'd like to fix that, but have one question:
In the Five version
from zope.app import zapi
factory = zapi.getUtility(IFactory, type_name)
was replaced by
factory = zope.component.getUtility(IFactory, type_name)
Was this a code modernization that should be ported to
zope.app.container? Or should I revert the change in Products.Five?
Keeping two different versions makes it unnecessarily hard to read the
Personally, I prefer yet an other version:
from zope.component import getUtility
factory = getUtility(IFactory, type_name)
But I don't want to change both files if there is no recommended version.
Maybe we don't need a strict policy for this, but some guidance would be
nice to have.
Any opinions? Any guidelines I missed?
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -