Hi there,

we maintain some modules that should work against different versions of dependent module. E.g. my z3c.sqlalchemy module should work with


Sqlalchemy 0.3.X and zope.interface 3.0.X
or
SQLAlchemy >=0.4.X and zope.interface>=3.3.0

The codebase right works with both combinations. I am not sure how test such configurations automatically because the dependent modules and their versions are fixed within the setup.py. Is there some way together with Buildout, zope.testing & friends?

Andreas
-  

Attachment: pgpjLL1OF2aDJ.pgp
Description: PGP signature

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to