Chris McDonough wrote:
> Alan Milligan wrote:
>> Hi,
>>
>> I'm in the midst of rolling repoze out on our BastionLinux RPM's (at 
>> https://linux.last-bastion.net/LBN/up2date/plope/6 (repoze.* and zope.*) 
>> for *exactly* what files and versions are being shipped).
>>
>> We're at zope-2.9.9, the latest release that runs up plone-2.5.x.  I've 
>> thus packaged up the required components on 
>> http://dist.repoze.org/zope2/2.9/
>>
>> However, the zope.interface-3.4.0 is from a later version of Z3 than 
>> ships with Z2 (I think this is still at 3.3) and when zope.app.component 
>> from the Z2 tree is invoked through paster, it dies horribly when it 
>> can't find zope.interface.adapter.Surrogate - which appears to have 
>> vanished between releases.  Downgrading to zope.interface-3.3.0, as 
>> shipped with zope-2.9.9 fixes this (insofar as zope2.wsgi now runs up 
>> from the command line).
> 
> Eek.  You're right.  I mispackaged.  The zope.interface version up there now 
> is 
> the 3.2 version that ships with Zope 2.9.  We maintain multiple indexes, and 
> we 
> haven't yet automated a buildbot to test them so it's exceedingly difficult 
> to 
> make sure they all work at all times.  Apologies.
> 
>> Similarly, the ZODB3 version (3.7.2) is later than that shipped in 
>> zope-2.9.9.  I don't expect any issues with this (yet at least) as I'm 
>> running vanilla zeo from zope-2.9.9
> 
> That doesn't cause any problem in our testing.
> 
>> Is this anomaly simply due to hoping that nobody will notice if the 
>> Z2.10 tarballs are foisted on Z2.9 users - or indeed are these genuinely 
>> required, and I'm about to enter module import hell?
> 
> No, I think you should be good now with the new distribution.  Thanks for the 
> notification.
> 
>> Note that the zope.proxy and zope.testing tarballs are similarly 
>> incorrect, but they too appear benign.
> 
> I also believe these are benign.
> 
> I'm currently running an easy_install to make sure.

Well it *would* have worked if easy_install didn't go off to download.zope.org 
to find the latest zope.interface package due to a promiscuous 
distribution_links in the ZODB package.  See also 
http://plope.com/Members/chrism/distribution_links_considered_harmful .. Ugh. 
I'll need to re-roll that ZODB egg without the dependency-links and put it up 
there.  I'll post when that's done.

- C

_______________________________________________
Repoze-dev mailing list
[EMAIL PROTECTED]
http://lists.repoze.org/listinfo/repoze-dev
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to