Hi. I have been working with z3c.dobbin 0.4.1 which uses zope.sqlalchemy and z3c.saconfig. The last usable state was 4 days ago when changes were made to release of zope.sqlalchemy where dependencies were changed without changing the version.

Revision 88953 was made to zope.sqlalchemy but shows the same package version as 88952 (where SA dependencies were changed to no longer include beta0.5.2). beta0.5.2 was the requirement for z3c.dobbin and it will not work with beta0.5.3. Malthe is currently making changes to dobbin in the interim so it will eventually work again.


I thought by checking out revision 88952 and using it as a dev egg in my buildout, I could get back to work. Is this a bug in buildout since dev egg should take precedence regardless? I guess there were some problems with how this was handled. If trunk had been marked as 0.3dev it might have made the difference because both were 0.3 regardless of the change of state and dependencies. When I run the buildout the dev egg's requires.txt is below regardess of what is in setup.py. Doesn't matter what I do my build fails. Any suggestions? Many thanks.

Regards,
David



requires.txt

setuptools
SQLAlchemy>=0.4.7,!=0.5.0beta1,!=0.5.0beta2
transaction
zope.interface

[test]
zope.testing
docutils


setup.py

    install_requires=[
      'setuptools',
      'SQLAlchemy==0.5.0beta2', # or >=0.5b3
      'transaction',
      'zope.interface',
      ],
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to