On Tuesday 16 September 2008, Tres Seaver wrote:
> > I guess we have to figure out a clever way to make a special extra
> > requires for Python 2.4, since elementtree and cElementTree are available
> > in PyPI.
>
> Something like this in setup.py?:
>
>   extra_requires = []
>   import sys
>   if sys.version_info[0:2] < (2, 5):
>       extra_requires.append(...)

Yeah, that should work.

Regards,
Stephan
-- 
Stephan Richter
Web Software Design, Development and Training
Google me. "Zope Stephan Richter"
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to