Benji York wrote:
> On Fri, Nov 14, 2008 at 7:23 PM, Hanno Schlichting <[EMAIL PROTECTED]> wrote:
>> Log message for revision 92953:
>> Copied over the UtilityTerm and UtilityVocabulary implementation from
>> zope.app.component to avoid a dependency.
> Instead of duplicating the code there should be a zope.utilityvocabulary
> package that both zope.sendmail and zope.app.component can use.
I agree in principal. In this case the code is extremely tiny, though.
I'm not sure if packages which consist of only two simple classes are
really that much of a good idea. There is an overhead in tracking
dependencies and maintaining packages in itself. When the benefit of
being able to reuse the same code outweighs this overhead is not clear
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -